summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2013-04-05 15:54:31 +0200
committerKarel Zak2013-04-05 15:54:31 +0200
commitece777e9de4abe3256cef3b6e6278056da3efef7 (patch)
treee5cc7b549ebfdaaf5f4ddb030150358732d53217 /configure.ac
parentbash-completion: rename shell-completion -> bash-completion (diff)
downloadkernel-qcow2-util-linux-ece777e9de4abe3256cef3b6e6278056da3efef7.tar.gz
kernel-qcow2-util-linux-ece777e9de4abe3256cef3b6e6278056da3efef7.tar.xz
kernel-qcow2-util-linux-ece777e9de4abe3256cef3b6e6278056da3efef7.zip
build-sys: add --disable-bash-completion
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd4e826a9..b45673304 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1353,6 +1353,13 @@ AC_ARG_WITH([bashcompletiondir],
])
AC_SUBST([bashcompletiondir], [$with_bashcompletiondir])
+AC_ARG_ENABLE([bash-completion],
+ AS_HELP_STRING([--disable-bash-completion], [do not install bash completion files]),
+ [], enable_bash_completion=yes
+)
+
+AM_CONDITIONAL(BUILD_BASH_COMPLETION, test "x$enable_bash_completion" = xyes)
+
AC_ARG_ENABLE([pg-bell],
AS_HELP_STRING([--disable-pg-bell], [let pg not ring the bell on invalid keys]),