summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2010-05-27 13:32:12 +0200
committerKarel Zak2010-06-01 11:09:23 +0200
commitee32c514b5d61765a3ca6305d247b91fc8d15d0e (patch)
tree321c3f00376055c9957a439c5ce70b16dabe5fcf /configure.ac
parenttaskset: use libc based cpu_set_t (diff)
downloadkernel-qcow2-util-linux-ee32c514b5d61765a3ca6305d247b91fc8d15d0e.tar.gz
kernel-qcow2-util-linux-ee32c514b5d61765a3ca6305d247b91fc8d15d0e.tar.xz
kernel-qcow2-util-linux-ee32c514b5d61765a3ca6305d247b91fc8d15d0e.zip
lib: add fallback for libc (uClibc) without CPU_ALLOC
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fe91a1a6..fae8db145 100644
--- a/configure.ac
+++ b/configure.ac
@@ -682,6 +682,17 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
])
+AC_CHECK_TYPES([cpu_set_t], [have_cpu_set_t=yes], [], [[
+#include <sched.h>
+]])
+
+AM_CONDITIONAL(HAVE_CPU_SET_T, [test "x$have_cpu_set_t" = xyes])
+
+AC_CHECK_DECLS([CPU_ALLOC], [], [], [[
+#include <sched.h>
+]])
+
+
dnl UTIL_SET_ARCH(ARCHNAME, PATTERN)
dnl ---------------------------------
AC_DEFUN([UTIL_SET_ARCH], [