summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIlias Mamedov2011-10-03 14:22:42 +0200
committerKarel Zak2011-10-03 14:25:43 +0200
commitf17f5f481a1c1d61853f1e01858311b38f7ee6ab (patch)
tree163b0e8736b6d993102ee287103601d50be78cad /configure.ac
parentdocs: add prlimit to the TODO file (diff)
downloadkernel-qcow2-util-linux-f17f5f481a1c1d61853f1e01858311b38f7ee6ab.tar.gz
kernel-qcow2-util-linux-f17f5f481a1c1d61853f1e01858311b38f7ee6ab.tar.xz
kernel-qcow2-util-linux-f17f5f481a1c1d61853f1e01858311b38f7ee6ab.zip
lsblk: add udev support
[kzak@redhat.com: - enable udev support by default - don't check for libudev.h - minor udev code refactoring in lsblk.c] Signed-off-by: Ilias Mamedov <arknir@yandex.ru> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fb0b0eb37..d12a4a037 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1111,11 +1111,28 @@ else
UTIL_CHECK_LIB(audit, audit_log_user_message)
case "$with_audit:$have_audit" in
yes:no)
- AC_MSG_ERROR([Audit selected but libaudit not found (or doesn't support audit_log_user_message())])
+ AC_MSG_ERROR([Audit selected but libaudit not found (or does not support audit_log_user_message())])
;;
esac
fi
+
+AC_ARG_WITH([udev], AS_HELP_STRING([--without-udev], [compile without udev support]),
+ [], with_udev=auto
+)
+
+if test "x$with_udev" = xno; then
+ AM_CONDITIONAL(HAVE_UDEV, false)
+else
+ UTIL_CHECK_LIB(udev, udev_new)
+ case "$with_udev:$have_udev" in
+ yes:no)
+ AC_MSG_ERROR([udev selected but libudev not found])
+ ;;
+ esac
+fi
+
+
AC_ARG_ENABLE([schedutils],
AS_HELP_STRING([--disable-schedutils], [do not build chrt, ionice, teskset]),
[], enable_schedutils=yes