summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2009-05-16 01:26:35 +0200
committerKarel Zak2009-05-22 10:06:14 +0200
commitf6076f557ef9385748db05ccadd4c3eb5a4d460c (patch)
treea4aa3154029c3f115c082f0b2725c9ee82492e0d /configure.ac
parentlibuuid: import UUID library from e2fsprogs (diff)
downloadkernel-qcow2-util-linux-f6076f557ef9385748db05ccadd4c3eb5a4d460c.tar.gz
kernel-qcow2-util-linux-f6076f557ef9385748db05ccadd4c3eb5a4d460c.tar.xz
kernel-qcow2-util-linux-f6076f557ef9385748db05ccadd4c3eb5a4d460c.zip
libuuid: add --disable-libuuid and LIBUUID_VERSION
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6c8d14087..70b89c4a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,9 @@ dnl libblkid version
LIBBLKID_VERSION="$PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_RELEASE"
LIBBLKID_DATE="10-Feb-2009"
+dnl libuuid version
+LIBUUID_VERSION="$PACKAGE_VERSION_MAJOR.$PACKAGE_VERSION_MINOR.$PACKAGE_VERSION_RELEASE"
+
# Check whether exec_prefix=/usr:
case $exec_prefix:$prefix in
NONE:NONE | NONE:/usr | /usr:*)
@@ -242,7 +245,7 @@ AC_ARG_ENABLE([mount],
[], enable_mount=check
)
build_mount=yes
-if test "${enable_mount}" = "no"; then
+if test "x$enable_mount" = xno; then
build_mount=no
elif test "x$linux_os" = xyes; then
if test "x$have_blkid" = xno && test "x$have_volume_id" = xno; then
@@ -255,6 +258,14 @@ fi
AM_CONDITIONAL(BUILD_MOUNT, test "x$build_mount" = xyes)
+AC_ARG_ENABLE([libuuid],
+ AS_HELP_STRING([--disable-libuuid], [do not build libuuid and uuid utilities]),
+ [], enable_libuuid=yes
+)
+AC_SUBST(LIBUUID_VERSION)
+AM_CONDITIONAL(BUILD_LIBUUID, test "x$enable_libuuid" = xyes)
+
+
AC_ARG_ENABLE([fsck],
AS_HELP_STRING([--enable-fsck], [do build fsck]),
[], enable_fsck=no