summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2015-03-03 11:36:59 +0100
committerKarel Zak2015-03-03 11:43:01 +0100
commitf71d1104df68e9ab7f06878c1c324566721acd66 (patch)
treee5dbce365fc74af2a663e3f016f657b746319a93 /configure.ac
parentlibfdisk: add {first,last}-lba header to sfdisk scritps (diff)
downloadkernel-qcow2-util-linux-f71d1104df68e9ab7f06878c1c324566721acd66.tar.gz
kernel-qcow2-util-linux-f71d1104df68e9ab7f06878c1c324566721acd66.tar.xz
kernel-qcow2-util-linux-f71d1104df68e9ab7f06878c1c324566721acd66.zip
build-sys: add --enable-usrdir-path
The directories /{sbin,bin} are symliks to /usr/{sbin,bin} on many systems. This patch add new ./configure option to remove the non-usr paths from the default $PATH environment variable. The default $PATH is hardcoded in login(1) and can be overwritten by /etc/login.defs. default: ./test_pathnames | grep DEFPATH _PATH_DEFPATH /usr/local/bin:/bin:/usr/bin _PATH_DEFPATH_ROOT /usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin --enable-usrdir-path: ./test_pathnames | grep DEFPATH _PATH_DEFPATH /usr/local/bin:/usr/bin _PATH_DEFPATH_ROOT /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin This patch does not modify install paths, you still have to care about --{bin,lib}dir configure options. Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f7c3f8e57..5d2b68503 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1846,6 +1846,16 @@ AS_IF([test "x$enable_sulogin_emergency_mount" = xyes], [
])
+AC_ARG_ENABLE([usrdir-path],
+ AS_HELP_STRING([--enable-usrdir-path], [use only /usr paths in PATH env. variable (recommended on systems with /bin -> /usr/bin symlinks)]),
+ [], [enable_usrdir_path=no]
+)
+
+AS_IF([test "x$enable_usrdir_path" == xyes], [
+ AC_DEFINE([USE_USRDIR_PATHS_ONLY], [1], [Define to 1 to remove /bin and /sbin from PATH env.variable])
+])
+
+
AC_ARG_ENABLE([makeinstall-chown],
AS_HELP_STRING([--disable-makeinstall-chown], [do not do chown-like operations during "make install"]),
[], [enable_makeinstall_chown=yes]