summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric W. Biederman2013-01-11 23:46:38 +0100
committerKarel Zak2013-01-17 13:17:13 +0100
commitf8aa8e9495dd89f39b7d0db5aab431cac02ea519 (patch)
tree3b60cc0fd926eb2fdd02122952322fbdf5067802 /configure.ac
parentRevert "unshare: support the switching of namespaces" (diff)
downloadkernel-qcow2-util-linux-f8aa8e9495dd89f39b7d0db5aab431cac02ea519.tar.gz
kernel-qcow2-util-linux-f8aa8e9495dd89f39b7d0db5aab431cac02ea519.tar.xz
kernel-qcow2-util-linux-f8aa8e9495dd89f39b7d0db5aab431cac02ea519.zip
nsenter: new command (light wrapper around setns)
Inspired by unshare, nsenter is a simple wrapper around setns that allows running a new process in the context of an existing process. Full paths may be specified to the namespace arguments so that namespace file descriptors may be used wherever they reside in the filesystem. Signed-off-by: "Eric W. Biederman" <ebiederm@xmission.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e937736b6..52deda848 100644
--- a/configure.ac
+++ b/configure.ac
@@ -867,6 +867,17 @@ if test "x$build_unshare" = xyes; then
AC_CHECK_FUNCS([unshare])
fi
+AC_ARG_ENABLE([nsenter],
+ AS_HELP_STRING([--disable-nsenter], [do not build nsenter]),
+ [], enable_nsenter=check
+)
+UL_BUILD_INIT([nsenter])
+UL_REQUIRES_LINUX([nsenter])
+UL_REQUIRES_SYSCALL_CHECK([setns], [UL_CHECK_SYSCALL([setns])])
+AM_CONDITIONAL(BUILD_NSENTER, test "x$build_nsenter" = xyes)
+if test "x$build_nsenter" = xyes; then
+ AC_CHECK_FUNCS([setns])
+fi
AC_ARG_ENABLE([arch],
AS_HELP_STRING([--enable-arch], [do build arch]),