summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2017-01-18 13:17:21 +0100
committerKarel Zak2017-01-18 13:17:21 +0100
commitfeda4342df1ced25df3d200ed23469e740196c86 (patch)
tree532ab044ba074a14c2e613b0b4ccb9f4dee9df68 /configure.ac
parentcolumn: rename --columns to --output-width (diff)
downloadkernel-qcow2-util-linux-feda4342df1ced25df3d200ed23469e740196c86.tar.gz
kernel-qcow2-util-linux-feda4342df1ced25df3d200ed23469e740196c86.tar.xz
kernel-qcow2-util-linux-feda4342df1ced25df3d200ed23469e740196c86.zip
build-sys: use -lm for scriptreplay if necessary
Reported-by: Bert van Hall <bert.vanhall@avionic-design.de> Addresses: https://github.com/karelzak/util-linux/pull/397 Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c50f07a47..fa3e6c831 100644
--- a/configure.ac
+++ b/configure.ac
@@ -432,6 +432,13 @@ AC_CHECK_FUNCS([updwtmpx updwtmpx], [have_gnu_utmpx=yes], [have_gnu_utmpx=no])
AM_CONDITIONAL([HAVE_OPENAT], [test "x$have_openat" = xyes])
+
+AC_CHECK_FUNCS([isnan], [],
+ [AC_CHECK_LIB([m], [isnan], [MATH_LIBS="-lm"])]
+)
+AC_SUBST([MATH_LIBS])
+
+
dnl lib/mononotic.c may require -lrt
AC_CHECK_FUNCS([clock_gettime], [],
[AC_CHECK_LIB([rt], [clock_gettime], [REALTIME_LIBS="-lrt"])]