summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak2012-05-29 14:54:06 +0200
committerKarel Zak2012-05-29 14:54:06 +0200
commitff4c5555d0c9e15d182bbf0cc738f5242b166024 (patch)
tree8e2b32ce7d3830eb22d87816afd45f0870301794 /configure.ac
parentbuild-sys: add --enable-chfn-chsh (diff)
downloadkernel-qcow2-util-linux-ff4c5555d0c9e15d182bbf0cc738f5242b166024.tar.gz
kernel-qcow2-util-linux-ff4c5555d0c9e15d182bbf0cc738f5242b166024.tar.xz
kernel-qcow2-util-linux-ff4c5555d0c9e15d182bbf0cc738f5242b166024.zip
build-sys: add --disable-su
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 03832a254..ad10cfd19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1054,6 +1054,15 @@ UL_BUILD_INIT([sulogin])
AM_CONDITIONAL(BUILD_SULOGIN, test "x$build_sulogin" = xyes)
+AC_ARG_ENABLE([su],
+ AS_HELP_STRING([--disable-su], [do not build su]),
+ [], enable_su=yes
+)
+UL_BUILD_INIT([su])
+UL_REQUIRES_HAVE([su], [security_pam_misc_h], [PAM header file])
+AM_CONDITIONAL(BUILD_SU, test "x$build_su" = xyes)
+
+
AC_ARG_ENABLE([schedutils],
AS_HELP_STRING([--disable-schedutils], [do not build chrt, ionice, teskset]),
[], enable_schedutils=yes