summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2009-02-18 15:43:34 +0100
committerKarel Zak2009-02-18 15:43:34 +0100
commit33bbc9593708f33815ce666d9eab43d5381e30cd (patch)
tree2b671fc55effd43ad242aeab48e661e319daac52 /lib/Makefile.am
parentpo: update list of .c files (diff)
downloadkernel-qcow2-util-linux-33bbc9593708f33815ce666d9eab43d5381e30cd.tar.gz
kernel-qcow2-util-linux-33bbc9593708f33815ce666d9eab43d5381e30cd.tar.xz
kernel-qcow2-util-linux-33bbc9593708f33815ce666d9eab43d5381e30cd.zip
lib: add test_ismounted for regression test
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 37205dcd6..cd4871aa3 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,13 +1,15 @@
include $(top_srcdir)/config/include-Makefile.am
-noinst_PROGRAMS = test_blkdev
+noinst_PROGRAMS = test_blkdev test_ismounted
-test_blkdev_SOURCES = $(top_srcdir)/lib/blkdev.c
+test_blkdev_SOURCES = blkdev.c
+test_ismounted_SOURCES = ismounted.c
if LINUX
-test_blkdev_SOURCES += $(top_srcdir)/lib/linux_version.c
+test_blkdev_SOURCES += linux_version.c
endif
-test_blkdev_CFLAGS = -DMAIN_TEST_BLKDEV
+test_blkdev_CFLAGS = -DTEST_PROGRAM
+test_ismounted_CFLAGS = -DTEST_PROGRAM