summaryrefslogtreecommitdiffstats
path: root/login-utils/Makefile.am
diff options
context:
space:
mode:
authorFabian Groffen2011-01-12 21:01:07 +0100
committerKarel Zak2011-01-17 16:32:39 +0100
commit0aeb57aca31816ca5b93cc10ad0fb9d62ad805de (patch)
tree15b5d1a3395da747dfaada6ac28f3a2b14b9b2e9 /login-utils/Makefile.am
parentbuild-sys: use WORDS_BIGENDIAN to determine platform byte-order (diff)
downloadkernel-qcow2-util-linux-0aeb57aca31816ca5b93cc10ad0fb9d62ad805de.tar.gz
kernel-qcow2-util-linux-0aeb57aca31816ca5b93cc10ad0fb9d62ad805de.tar.xz
kernel-qcow2-util-linux-0aeb57aca31816ca5b93cc10ad0fb9d62ad805de.zip
build-sys: improve check for crypt
Check for crypt.h existence, and use it if available over using unistd.h for which a certain feature level has to be set to export a definition for crypt. On Solaris this set causes a standards conflict in the headers, because at the time of this check C99 mode is already enabled, which implies certain standards non-compatible with _XOPEN_SOURCE. 92 #define _XOPEN_SOURCE 93 #include <unistd.h> configure:16259: gcc -std=gnu99 -c -g -O2 conftest.c >&5 In file included from /usr/include/unistd.h:18, from conftest.c:93: /prefix/gentoo/usr/lib/gcc/i386-pc-solaris2.10/4.4.5/include-fixed/sys/feature_tests.h:341:2: error: #error "Compiler or options invalid for pre-UNIX 03 X/Open applications and pre-2001 POSIX applications" configure.ac: improve crypt check login-utils/my_crypt.h: replace old GNU_LIBRARY check with autoconf define for crypt.h [kzak@redhat.com: - remove my_crypt.h] Signed-off-by: Fabian Groffen <grobian@gentoo.org> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'login-utils/Makefile.am')
-rw-r--r--login-utils/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/login-utils/Makefile.am b/login-utils/Makefile.am
index c490999d9..9c64149f1 100644
--- a/login-utils/Makefile.am
+++ b/login-utils/Makefile.am
@@ -34,10 +34,9 @@ login_ldadd_common =
chfn_SOURCES = chfn.c $(chfn_chsh_common)
chsh_SOURCES = chsh.c $(chfn_chsh_common)
-chfn_chsh_common = islocal.c setpwnam.c islocal.h my_crypt.h setpwnam.h \
+chfn_chsh_common = islocal.c setpwnam.c islocal.h setpwnam.h \
$(top_srcdir)/lib/env.c
-login_SOURCES = login.c login.h my_crypt.h $(top_srcdir)/lib/setproctitle.c
-newgrp_SOURCES = newgrp.c my_crypt.h
+login_SOURCES = login.c login.h $(top_srcdir)/lib/setproctitle.c
vipw_SOURCES = vipw.c setpwnam.h
chfn_LDADD = $(login_ldadd_common)