summaryrefslogtreecommitdiffstats
path: root/login-utils/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2012-05-29 15:20:44 +0200
committerKarel Zak2012-05-29 15:20:44 +0200
commitcc76731e7da26a48c306336a1d142d44186c2a26 (patch)
tree049cf8e02bc8789cee64227209075b6a9b4faa61 /login-utils/Makefile.am
parentbuild-sys: add --enable-newgrp (diff)
downloadkernel-qcow2-util-linux-cc76731e7da26a48c306336a1d142d44186c2a26.tar.gz
kernel-qcow2-util-linux-cc76731e7da26a48c306336a1d142d44186c2a26.tar.xz
kernel-qcow2-util-linux-cc76731e7da26a48c306336a1d142d44186c2a26.zip
build-sys: add --enable-vipw
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'login-utils/Makefile.am')
-rw-r--r--login-utils/Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/login-utils/Makefile.am b/login-utils/Makefile.am
index 624ddc393..baa79490d 100644
--- a/login-utils/Makefile.am
+++ b/login-utils/Makefile.am
@@ -100,28 +100,21 @@ endif
endif # BUILD_NEWGRP
-if BUILD_LOGIN_UTILS
-usrsbin_exec_PROGRAMS += \
- vipw
-dist_man_MANS += \
- vigr.8 \
- vipw.8
-
+if BUILD_VIPW
+usrsbin_exec_PROGRAMS += vipw
+dist_man_MANS += vigr.8 vipw.8
vipw_SOURCES = \
vipw.c \
setpwnam.h \
$(top_srcdir)/lib/fileutils.c
-
vipw_LDADD =
-
if HAVE_SELINUX
vipw_LDADD += -lselinux
endif
-
install-exec-hook::
cd $(DESTDIR)$(usrsbin_execdir) && ln -sf vipw vigr
+endif # BUILD_VIPW
-endif
noinst_PROGRAMS = test_islocal test_logindefs
test_islocal_SOURCES = islocal.c