summaryrefslogtreecommitdiffstats
path: root/shlibs/mount/src/Makefile.am
diff options
context:
space:
mode:
authorKarel Zak2010-01-13 22:08:16 +0100
committerKarel Zak2010-06-03 15:20:11 +0200
commit6bd8b7a79dffb532ae8639e563f75005a10bc41d (patch)
tree470fe4db5d45f28e2f5c49db4388d315f39e5b61 /shlibs/mount/src/Makefile.am
parentlibmount: rename mnt_optls_iterate_options() (diff)
downloadkernel-qcow2-util-linux-6bd8b7a79dffb532ae8639e563f75005a10bc41d.tar.gz
kernel-qcow2-util-linux-6bd8b7a79dffb532ae8639e563f75005a10bc41d.tar.xz
kernel-qcow2-util-linux-6bd8b7a79dffb532ae8639e563f75005a10bc41d.zip
libmount: add fstab/mtab/mountinfo parsing routines
Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'shlibs/mount/src/Makefile.am')
-rw-r--r--shlibs/mount/src/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/shlibs/mount/src/Makefile.am b/shlibs/mount/src/Makefile.am
index de265c9d5..5d80779e0 100644
--- a/shlibs/mount/src/Makefile.am
+++ b/shlibs/mount/src/Makefile.am
@@ -13,7 +13,7 @@ libmount_la_SOURCES = $(mountinc_HEADERS)
nodist_libmount_la_SOURCES = mount.h version.c utils.c test.c init.c cache.c \
optstr.c optmap.c optent.c optls.c iter.c list.h lock.c \
- fs.c \
+ fs.c tab.c tab_parse.c \
$(top_srcdir)/lib/canonicalize.c
libmount_la_LIBADD = $(ul_libblkid_la)
@@ -42,7 +42,8 @@ uninstall-hook:
rm -f $(DESTDIR)$(libdir)/libmount.so*
# tests
-noinst_PROGRAMS = test_version test_cache test_optstr test_optls test_lock
+noinst_PROGRAMS = test_version test_cache test_optstr test_optls test_lock \
+ test_tab
tests_cppflags = $(AM_CPPFLAGS) -DTEST_PROGRAM
tests_ldadd = .libs/libmount.a $(ul_libblkid_la)
@@ -65,3 +66,7 @@ test_optls_LDADD = $(tests_ldadd)
test_lock_SOURCES = lock.c
test_lock_CPPFLAGS = $(tests_cppflags)
test_lock_LDADD = $(tests_ldadd)
+
+test_tab_SOURCES = tab_parse.c tab.c
+test_tab_CPPFLAGS = $(tests_cppflags)
+test_tab_LDADD = $(tests_ldadd)