summaryrefslogtreecommitdiffstats
path: root/sys-utils/Makefile.am
diff options
context:
space:
mode:
authorDavidlohr Bueso2011-02-03 21:41:56 +0100
committerKarel Zak2011-02-08 15:40:48 +0100
commit15673c1598e8eb138b569f9e86421d1b60f76c23 (patch)
treea8bbb687d1390abb4ff2dec7a155bb7e84d0e17b /sys-utils/Makefile.am
parentlscpu: cleanup usage() (diff)
downloadkernel-qcow2-util-linux-15673c1598e8eb138b569f9e86421d1b60f76c23.tar.gz
kernel-qcow2-util-linux-15673c1598e8eb138b569f9e86421d1b60f76c23.tar.xz
kernel-qcow2-util-linux-15673c1598e8eb138b569f9e86421d1b60f76c23.zip
dmesg: use strtol_or_err instead of atoi
We shouldn't be accepting things like 'dmesg -n 2crapinput' This patch also changes the exit's value to use EXIT_* constants. Signed-off-by: Davidlohr Bueso <dave@gnu.org>
Diffstat (limited to 'sys-utils/Makefile.am')
-rw-r--r--sys-utils/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/sys-utils/Makefile.am b/sys-utils/Makefile.am
index ee6f2d74c..d916d3d04 100644
--- a/sys-utils/Makefile.am
+++ b/sys-utils/Makefile.am
@@ -29,6 +29,7 @@ cytune_SOURCES = cytune.c cyclades.h
tunelp_SOURCES = tunelp.c lp.h
fstrim_SOURCES = fstrim.c $(top_srcdir)/lib/strutils.c
rtcwake_SOURCES = rtcwake.c $(top_srcdir)/lib/strutils.c
+dmesg_SOURCES = dmesg.c $(top_srcdir)/lib/strutils.c
if BUILD_FALLOCATE
usrbin_exec_PROGRAMS += fallocate