summaryrefslogtreecommitdiffstats
path: root/sys-utils/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering2012-04-05 23:31:41 +0200
committerKarel Zak2012-04-16 14:24:49 +0200
commit8fb6a2de79540d85567c40e0e5e8d42a612f3af2 (patch)
tree6d14e1c454ae7f23c739a094ba0f0a4ab0374a8d /sys-utils/Makefile.am
parentcal: Fix building under uClibc. (diff)
downloadkernel-qcow2-util-linux-8fb6a2de79540d85567c40e0e5e8d42a612f3af2.tar.gz
kernel-qcow2-util-linux-8fb6a2de79540d85567c40e0e5e8d42a612f3af2.tar.xz
kernel-qcow2-util-linux-8fb6a2de79540d85567c40e0e5e8d42a612f3af2.zip
wdctl: add watchdog status tool
For: util-linux This patch adds a tiny tool "wdctl" which may be used to query the status of Linux watchdog devices (/dev/watchdog). This will simply query all fields that may be queried from the device and print them nicely formatted. Signed-off-by: Lennart Poettering <lennart@poettering.net>
Diffstat (limited to 'sys-utils/Makefile.am')
-rw-r--r--sys-utils/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-utils/Makefile.am b/sys-utils/Makefile.am
index 828c48d9b..f6ae6ee8e 100644
--- a/sys-utils/Makefile.am
+++ b/sys-utils/Makefile.am
@@ -25,7 +25,7 @@ if LINUX
# Linux-only utils with no another dependencies. All another dependencies have
# to be resolved in configure.ac end exported to makefiles by BUILD_*.
#
-bin_PROGRAMS += dmesg
+bin_PROGRAMS += dmesg wdctl
sbin_PROGRAMS += ctrlaltdel fsfreeze fstrim
usrbin_exec_PROGRAMS += cytune setarch
usrsbin_exec_PROGRAMS += ldattach tunelp rtcwake
@@ -179,6 +179,7 @@ ipcmk_SOURCES = ipcmk.c $(top_srcdir)/lib/strutils.c
ipcrm_SOURCES = ipcrm.c $(top_srcdir)/lib/strutils.c
flock_SOURCES = flock.c $(top_srcdir)/lib/strutils.c
ldattach_SOURCES = ldattach.c $(top_srcdir)/lib/strutils.c
+wdctl_SOURCES = wdctl.c
if BUILD_MOUNTPOINT
bin_PROGRAMS += mountpoint