summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83b76ae1f..2c1ffbc05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -359,6 +359,7 @@ AC_CHECK_FUNCS([ \
scandirat \
setresgid \
setresuid \
+ sched_setattr \
sigqueue \
srandom \
strnchr \
@@ -1776,6 +1777,10 @@ UL_BUILD_INIT([chrt], [check])
UL_REQUIRES_BUILD([chrt], [schedutils])
AM_CONDITIONAL([BUILD_CHRT], [test "x$build_chrt" = xyes])
+AS_IF([test "x$build_chrt" = xyes], [
+ UL_CHECK_SYSCALL([sched_setattr])
+])
+
AC_ARG_ENABLE([wall],
AS_HELP_STRING([--disable-wall], [do not build wall]),