summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 17917af7b..5cee8cfa4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,11 +158,17 @@ bsd_os=no
AS_CASE([${host_os}],
[*linux*],
[linux_os=yes],
+ [*darwin*],
+ [darwin_os=yes],
[*bsd*],
[bsd_os=yes])
AM_CONDITIONAL([LINUX], [test "x$linux_os" = xyes])
+AM_CONDITIONAL([DARWIN], [test "x$darwin_os" = xyes])
AM_CONDITIONAL([BSD], [test "x$bsd_os" = xyes])
+AS_IF([test "x$darwin_os" = xyes], [
+ AC_DEFINE([_DARWIN_C_SOURCE], [1], [Enable MAP_ANON in sys/mman.h on Mac OS X])
+])
dnl define ARCH_<NAME> conditionals
UL_SET_ARCH([I86], [i?86-*])