summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5b558ec11..387372fd9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,9 +136,17 @@ PKG_PROG_PKG_CONFIG
GTK_DOC_CHECK([1.10])
AC_PATH_PROG([XSLTPROC], [xsltproc])
+
linux_os=no
-AS_CASE([${host_os}], [*linux*], [linux_os=yes])
+bsd_os=no
+AS_CASE([${host_os}],
+ [*linux*],
+ [linux_os=yes],
+ [*bsd*],
+ [bsd_os=yes])
AM_CONDITIONAL([LINUX], [test "x$linux_os" = xyes])
+AM_CONDITIONAL([BSD], [test "x$bsd_os" = xyes])
+
dnl define ARCH_<NAME> conditionals
UL_SET_ARCH([I86], [i?86-*])