summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 84148abd3..fec2e4d79 100644
--- a/configure.ac
+++ b/configure.ac
@@ -958,7 +958,7 @@ UL_REQUIRES_HAVE([cramfs], [z], [z library])
AM_CONDITIONAL(BUILD_CRAMFS, test "x$build_cramfs" = xyes)
-AC_ARG_ENABLE([BUILD_BFS],
+AC_ARG_ENABLE([bfs],
AS_HELP_STRING([--disable-bfs], [do not build mkfs.bfs]),
[], enable_bfs=yes
)
@@ -966,6 +966,15 @@ UL_BUILD_INIT([bfs])
AM_CONDITIONAL(BUILD_BFS, test "x$build_bfs" = xyes)
+AC_ARG_ENABLE([fdformat],
+ AS_HELP_STRING([--disable-fdformat], [do not build fdformat]),
+ [], enable_fdformat=yes
+)
+UL_BUILD_INIT([fdformat])
+UL_REQUIRES_LINUX([fdformat])
+AM_CONDITIONAL(BUILD_FDFORMAT, test "x$build_fdformat" = xyes)
+
+
AC_ARG_ENABLE([hwclock],
AS_HELP_STRING([--disable-hwclock], [do not build hwclock]),
[], enable_hwclock=check