summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 984ad597d..276a6ef35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -794,16 +794,14 @@ else
fi
AM_CONDITIONAL(BUILD_CRAMFS, test "x$build_cramfs" = xyes)
+
+enable_lsblk=check
build_lsblk=yes
-if test "x$have_openat" = xno; then
- AC_MSG_WARN([openat() function not found; do not build lsblk])
- build_lsblk=no
-elif test "x$linux_os" = xno; then
- AC_MSG_WARN([non-linux system; do not build lsblk])
- build_lsblk=no
-fi
+UL_REQUIRES_LINUX([lsblk])
+UL_REQUIRES_BUILD([lsblk], [libblkid])
AM_CONDITIONAL(BUILD_LSBLK, test "x$build_lsblk" = xyes)
+
AC_ARG_ENABLE([switch_root],
AS_HELP_STRING([--disable-switch_root], [do not build switch_root]),
[], enable_switch_root=check