summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3002e77a2..75e869064 100644
--- a/configure.ac
+++ b/configure.ac
@@ -394,7 +394,14 @@ AC_CHECK_FUNCS([timer_create],
[AC_CHECK_LIB([rt], [timer_create], [
have_timer="yes"
REALTIME_LIBS="-lrt"
- ])]
+ ],[
+ AC_SEARCH_LIBS([timer_create], [rt], [
+ AC_MSG_RESULT(yes)
+ have_timer="yes"
+ REALTIME_LIBS="-lrt -lpthread"
+ ],[], [-lpthread]
+ )
+ ])]
)
AC_SUBST([REALTIME_LIBS])