summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index f34bb9286..2a185f343 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -4,16 +4,20 @@ AM_CPPFLAGS += -DTEST_PROGRAM
noinst_PROGRAMS = test_blkdev test_ismounted test_wholedisk test_mangle \
test_strtosize test_tt
+if LINUX
if HAVE_CPU_SET_T
noinst_PROGRAMS += test_cpuset
endif
+endif
test_blkdev_SOURCES = blkdev.c
test_ismounted_SOURCES = ismounted.c
test_wholedisk_SOURCES = wholedisk.c
test_mangle_SOURCES = mangle.c
test_strtosize_SOURCES = strtosize.c
+if LINUX
test_cpuset_SOURCES = cpuset.c
+endif
test_tt_SOURCES = tt.c
if LINUX