summaryrefslogtreecommitdiffstats
path: root/misc-utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'misc-utils/Makefile.am')
-rw-r--r--misc-utils/Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/misc-utils/Makefile.am b/misc-utils/Makefile.am
new file mode 100644
index 000000000..b9d30e331
--- /dev/null
+++ b/misc-utils/Makefile.am
@@ -0,0 +1,68 @@
+include $(top_srcdir)/config/include-Makefile.am
+
+bin_PROGRAMS =
+
+usrbin_PROGRAMS = cal ddate logger look mcookie \
+ namei script whereis
+
+mcookie_LDADD = $(top_srcdir)/lib/libmd5.la
+
+usrbin_SCRIPTS = chkdupexe scriptreplay
+
+chkdupexe: chkdupexe.pl
+ sed -e 's,[@]PERL[@],$(PERL),g' < chkdupexe.pl > chkdupexe
+
+scriptreplay: scriptreplay.pl
+ sed -e 's,[@]PERL[@],$(PERL),g' < scriptreplay.pl > scriptreplay
+
+CLEANFILES = chkdupexe scriptreplay
+
+man_MANS = cal.1 chkdupexe.1 ddate.1 logger.1 look.1 mcookie.1 \
+ namei.1 script.1 whereis.1
+
+if HAVE_NCURSES
+cal_LDADD = -lncurses
+else
+if HAVE_TERMCAP
+cal_LDADD = -ltermcap
+endif
+endif
+
+if HAVE_LIBUTIL
+script_LDADD = -lutil
+endif
+
+if HAVE_NCURSES
+usrbin_PROGRAMS += setterm
+man_MANS += setterm.1
+setterm_LDADD = -lncurses
+endif
+
+if BUILD_KILL
+bin_PROGRAMS += kill
+kill_SOURCES = kill.c procs.c
+man_MANS += kill.1
+endif
+
+if BUILD_RENAME
+usrbin_PROGRAMS += rename
+man_MANS += rename.1
+endif
+
+if BUILD_RESET
+usrbin_SCRIPTS += reset
+man_MANS += reset.1
+endif
+
+if BUILD_WRITE
+
+usrbin_PROGRAMS += write
+man_MANS += write.1
+
+if USE_TTY_GROUP
+install-data-hook::
+ chgrp tty $(DESTDIR)$(usrbindir)/write
+ chmod g+s $(DESTDIR)$(usrbindir)/write
+endif
+
+endif