summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index b0e63740b..d5bbf201c 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -91,6 +91,9 @@ mtab_lock_test_SOURCES = fstab.c $(srcs_common) $(hdrs_mount)
mtab_lock_test_CPPFLAGS = -DMAIN_TEST_MTABLOCK $(AM_CPPFLAGS)
install-exec-hook:
+ cd $(DESTDIR)$(sbindir) && ln -sf swapon swapoff
+if MAKEINSTALL_DO_SETUID
chmod 4755 $(DESTDIR)$(bindir)/mount
chmod 4755 $(DESTDIR)$(bindir)/umount
- cd $(DESTDIR)$(sbindir) && ln -sf swapon swapoff
+endif
+