summaryrefslogtreecommitdiffstats
path: root/mount/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mount/Makefile.am')
-rw-r--r--mount/Makefile.am48
1 files changed, 30 insertions, 18 deletions
diff --git a/mount/Makefile.am b/mount/Makefile.am
index d8bd77d17..6544b4dfa 100644
--- a/mount/Makefile.am
+++ b/mount/Makefile.am
@@ -4,26 +4,32 @@ bin_PROGRAMS = mount umount
dist_man_MANS = fstab.5 mount.8 umount.8
# generic sources for all programs (mount, umount)
-srcs_common = sundries.c $(top_srcdir)/lib/canonicalize.c sundries.h
+srcs_common = \
+ sundries.c \
+ $(top_srcdir)/lib/canonicalize.c \
+ sundries.h
# generic header for mount and umount
hdrs_mount = fstab.h mount_mntent.h mount_constants.h getusername.h
# generic sources for mount and umount
-srcs_mount = $(srcs_common) $(hdrs_mount) \
- fstab.c \
- mount_mntent.c \
- getusername.c \
- devname.c devname.h \
- $(top_srcdir)/lib/env.c \
- $(top_srcdir)/lib/linux_version.c \
- $(top_srcdir)/lib/blkdev.c \
- $(top_srcdir)/lib/fsprobe.c \
- $(top_srcdir)/lib/mangle.c \
- $(top_srcdir)/lib/at.c \
- $(top_srcdir)/lib/sysfs.c \
- $(top_srcdir)/lib/loopdev.c \
- $(top_srcdir)/lib/strutils.c
+srcs_mount = \
+ $(srcs_common) \
+ $(hdrs_mount) \
+ devname.c \
+ devname.h \
+ fstab.c \
+ getusername.c \
+ mount_mntent.c \
+ $(top_srcdir)/lib/at.c \
+ $(top_srcdir)/lib/blkdev.c \
+ $(top_srcdir)/lib/env.c \
+ $(top_srcdir)/lib/fsprobe.c \
+ $(top_srcdir)/lib/linux_version.c \
+ $(top_srcdir)/lib/loopdev.c \
+ $(top_srcdir)/lib/mangle.c \
+ $(top_srcdir)/lib/strutils.c \
+ $(top_srcdir)/lib/sysfs.c
# generic flags for all programs
# -- note that pkg-config autoconf macros (pkg.m4) does not differentiate
@@ -33,7 +39,10 @@ ldadd_static = $(ul_libblkid_la)
cflags_common = $(AM_CFLAGS) -I$(ul_libblkid_incdir)
ldflags_static = -all-static
-mount_SOURCES = mount.c $(srcs_mount) $(top_srcdir)/lib/setproctitle.c
+mount_SOURCES = \
+ mount.c \
+ $(srcs_mount) \
+ $(top_srcdir)/lib/setproctitle.c
mount_CFLAGS = $(SUID_CFLAGS) $(cflags_common)
mount_LDFLAGS = $(SUID_LDFLAGS) $(AM_LDFLAGS)
mount_LDADD = $(ldadd_common)
@@ -83,7 +92,11 @@ endif
if !BUILD_LIBMOUNT_MOUNT
noinst_PROGRAMS = mtab_lock_test
-mtab_lock_test_SOURCES = fstab.c $(srcs_common) $(top_srcdir)/lib/strutils.c $(hdrs_mount)
+mtab_lock_test_SOURCES = \
+ fstab.c \
+ $(hdrs_mount) \
+ $(srcs_common) \
+ $(top_srcdir)/lib/strutils.c
mtab_lock_test_CPPFLAGS = -DMAIN_TEST_MTABLOCK $(AM_CPPFLAGS)
endif
@@ -92,4 +105,3 @@ if MAKEINSTALL_DO_SETUID
chmod 4755 $(DESTDIR)$(bindir)/mount
chmod 4755 $(DESTDIR)$(bindir)/umount
endif
-