summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Darmochwal2010-10-05 12:45:20 +0200
committerJan Darmochwal2010-10-05 12:45:20 +0200
commit610840384ff2a04d640ca4d8fe100019bab0ba16 (patch)
treefaea71083d0c33f5389a9833f9576564cf0248eb /CMakeLists.txt
parentAllow sessions to be active for a given date range (diff)
downloadvmchooser-610840384ff2a04d640ca4d8fe100019bab0ba16.tar.gz
vmchooser-610840384ff2a04d640ca4d8fe100019bab0ba16.tar.xz
vmchooser-610840384ff2a04d640ca4d8fe100019bab0ba16.zip
simple PVS configuration in vmchooser
This patch adds a GroupBox with PVS access restriction options to vmchooser. Vmchooser checks if a PVS daemon is running and if so, displays some access configuration options. The options will be sent to the PVS daemon after a session has been started (just before vmchooser exits). All PVS configuration program logic is contained in the Dialog class. (It would probably be better to use a custom widget for the PVS options.) The file org.openslx.pvs.xml has been copied from a PVS build. This file has to be updated manually when the PVS D-Bus specification changes.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3924f13..0bc9e02 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,9 @@ QT4_ADD_RESOURCES(VMCHOOSER_RC_SOURCES ${VMCHOOSER_RESOURCES})
QT4_WRAP_UI(VMCHOOSER_UI_HEADERS ${VMCHOOSER_UIS})
QT4_WRAP_CPP(VMCHOOSER_MOC_SOURCES ${VMCHOOSER_MOC_HEADERS})
+# run qdbusxml2cpp on org.openslx.pvs.xml (taken from pvs build)
+QT4_ADD_DBUS_INTERFACE(VMCHOOSER_SOURCES src/org.openslx.pvs.xml pvsinterface )
+
#
# build vmchooser
#