summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Darmochwal2010-10-07 16:56:12 +0200
committerJan Darmochwal2010-10-07 16:56:12 +0200
commite7e9cf2849d0000acf47ecde86e4853687a03409 (patch)
treeaa811c315fa49eccf3691f932ebbc8b28d67fa14 /CMakeLists.txt
parentAdded files to parse command line options (diff)
downloadvmchooser-e7e9cf2849d0000acf47ecde86e4853687a03409.tar.gz
vmchooser-e7e9cf2849d0000acf47ecde86e4853687a03409.tar.xz
vmchooser-e7e9cf2849d0000acf47ecde86e4853687a03409.zip
Tidy up the code
* fixed compiler warnings, added -Werror to CMakeLists.txt * removed LibXml2 and boost stuff from CMakeLists.txt * fixed some things cpplint.py complains about: * make single-argument constructors explicit * add space before if/for/while/... * don't put { on a line of its own * remove space after ! operator * add space between // and comment * remove extra space before ( in function call * remove extra space before ) * shorten lines to <= 80 characters * remove blank lines at the start of a code block * maybe others
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt31
1 files changed, 1 insertions, 30 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9601a66..0f26a29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ cmake_minimum_required(VERSION 2.6)
project(vmchooser)
set(CMAKE_BUILD_TYPE Debug)
-set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -Wextra")
+set(CMAKE_CXX_FLAGS_DEBUG "-O0 -g -Wall -Wextra -Werror")
set(CMAKE_CXX_FLAGS_RELEASE "-O3 -march=native -Wall -Wextra -Werror")
set(CMAKE_VERBOSE_MAKEFILE TRUE)
@@ -20,33 +20,6 @@ file(GLOB_RECURSE VMCHOOSER_TSS src/i18n/*.ts)
include_directories(${CMAKE_CURRENT_BINARY_DIR})
#
-# Boost libraries
-#
-set(Boost_USE_STATIC_LIBS ON)
-find_package(Boost COMPONENTS "filesystem" "regex" "system" REQUIRED)
-if(Boost_FOUND)
- message(STATUS "Boost libraries found")
- #message(STATUS "Boost_LIBRARIES=${Boost_LIBRARIES}")
- link_directories(${Boost_LIBRARY_DIRS})
- include_directories(${Boost_INCLUDE_DIRS})
-else(Boost_FOUND)
- message(FATAL_ERROR "Boost libraries not found")
-endif(Boost_FOUND)
-
-#
-# LibXml2 library
-#
-find_package(LibXml2 REQUIRED)
-if(LIBXML2_FOUND)
- # TODO: this sucks, but we will get rid of libxml2 anyway
- message(STATUS "LibXml2 found")
- set(LIBXML2_INCLUDE_DIRS "/usr/include/libxml2")
- include_directories(${LIBXML2_INCLUDE_DIRS})
-else(LIBXML2_FOUND)
- message(FATAL_ERROR "LibXml2 not found")
-endif(LIBXML2_FOUND)
-
-#
# Qt4
#
find_package(Qt4 4.5.0 REQUIRED)
@@ -105,8 +78,6 @@ add_executable(vmchooser
target_link_libraries(vmchooser
${QT_LIBRARIES}
- ${Boost_LIBRARIES}
- ${LIBXML2_LIBRARIES}
)
#install(TARGETS vmchooser RUNTIME DESTINATION