summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Braun2010-10-04 00:22:14 +0200
committerSebastien Braun2010-10-05 18:15:48 +0200
commit266eb5fb14c07e67aa211a5860e9abf3009136e3 (patch)
tree9eeb8b159edf6e83880c056f1177cebec2ad354c /CMakeLists.txt
parentDefect #715, apply patch by Sébastien (diff)
downloadpvs-266eb5fb14c07e67aa211a5860e9abf3009136e3.tar.gz
pvs-266eb5fb14c07e67aa211a5860e9abf3009136e3.tar.xz
pvs-266eb5fb14c07e67aa211a5860e9abf3009136e3.zip
Implement first version of basic input event support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2153497..ec688b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,8 +29,16 @@ FIND_PACKAGE( VNC REQUIRED )
INCLUDE_DIRECTORIES(
${CMAKE_SOURCE_DIR}
${CMAKE_BINARY_DIR}
+ ${X11_INCLUDE_DIR}
+ ${X11_XTest_INCLUDE_PATH}
)
+IF(NOT X11_XTest_FOUND)
+ MESSAGE(FATAL_ERROR "Could not find X11 extension XTest. It is needed for PVS")
+ENDIF()
+
+ADD_SUBDIRECTORY(src/input)
+
################################################################################
# Variables
################################################################################
@@ -299,18 +307,22 @@ TARGET_LINK_LIBRARIES( pvsmgr
${QT_LIBRARIES}
${VNC_LIBRARIES}
${X11_LIBRARIES}
+ pvsinput
)
TARGET_LINK_LIBRARIES( pvsmgrtouch
${QT_LIBRARIES}
${VNC_LIBRARIES}
${X11_LIBRARIES}
+ pvsinput
)
TARGET_LINK_LIBRARIES( pvs
${QT_LIBRARIES}
${VNC_LIBRARIES}
${X11_LIBRARIES}
+ ${X11_XTest_LIB}
+ pvsinput
)
TARGET_LINK_LIBRARIES( pvsgui