summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Braun2010-10-05 19:04:36 +0200
committerSebastien Braun2010-10-05 19:58:04 +0200
commit43038c98f8cc48cfded692ea44e02e93597da305 (patch)
treea6b4562d2e6a664923c10243e3ce0494a0055439 /CMakeLists.txt
parentUpdate translation files (1) (diff)
downloadpvs-43038c98f8cc48cfded692ea44e02e93597da305.tar.gz
pvs-43038c98f8cc48cfded692ea44e02e93597da305.tar.xz
pvs-43038c98f8cc48cfded692ea44e02e93597da305.zip
Add hard requirement for XInput library.
XInput2 will be preferred if its presence is detected.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec688b5..dab8b1d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,10 +31,14 @@ INCLUDE_DIRECTORIES(
${CMAKE_BINARY_DIR}
${X11_INCLUDE_DIR}
${X11_XTest_INCLUDE_PATH}
+ ${X11_Xinput_INCLUDE_PATH}
)
IF(NOT X11_XTest_FOUND)
- MESSAGE(FATAL_ERROR "Could not find X11 extension XTest. It is needed for PVS")
+ MESSAGE(FATAL_ERROR "Could not find X11 extension XTest or its developer files.")
+ENDIF()
+IF(NOT X11_Xinput_FOUND)
+ MESSAGE(FATAL_ERROR "Could not find X11 extension Xinput or its developer files.")
ENDIF()
ADD_SUBDIRECTORY(src/input)
@@ -322,6 +326,7 @@ TARGET_LINK_LIBRARIES( pvs
${VNC_LIBRARIES}
${X11_LIBRARIES}
${X11_XTest_LIB}
+ ${X11_Xinput_LIB}
pvsinput
)