summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohann Latocha2010-08-28 18:42:35 +0200
committerJohann Latocha2010-08-28 18:42:35 +0200
commit513773016bff78145bf84760f3766013f0887c28 (patch)
tree44e411268f1baeb41f2d2e909b47af918e05f7ab /CMakeLists.txt
parentMore debugout and icon bug fixed (diff)
downloadpvs-513773016bff78145bf84760f3766013f0887c28.tar.gz
pvs-513773016bff78145bf84760f3766013f0887c28.tar.xz
pvs-513773016bff78145bf84760f3766013f0887c28.zip
Uninstall target added
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e364528..4c85954 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -375,6 +375,15 @@ ENDIF(WIN32)
INSTALL( PROGRAMS misc/pvs-vncsrv DESTINATION bin)
INSTALL( FILES ${CMAKE_BINARY_DIR}/org.openslx.pvs.service DESTINATION share/dbus-1/services )
+# add uninstall target to our makefile
+CONFIGURE_FILE(
+ "${CMAKE_CURRENT_SOURCE_DIR}/Uninstall.cmake"
+ "${CMAKE_CURRENT_BINARY_DIR}/Uninstall.cmake"
+ IMMEDIATE @ONLY)
+
+ADD_CUSTOM_TARGET(uninstall
+ "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/Uninstall.cmake")
+
# add package target to our makefile
SET( CPACK_GENERATOR "DEB;RPM" )
SET( CPACK_SET_DESTDIR "ON" )