summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Braun2010-07-10 04:03:20 +0200
committerSebastien Braun2010-07-10 04:03:20 +0200
commitcf1ddf0b9d55b8ca8544b0ae25e8fa08738b2049 (patch)
treef659cd600471f07445aecdfffcb340ed8df6b963 /CMakeLists.txt
parentDefect #715, apply patch by Sébastien (diff)
downloadpvs-cf1ddf0b9d55b8ca8544b0ae25e8fa08738b2049.tar.gz
pvs-cf1ddf0b9d55b8ca8544b0ae25e8fa08738b2049.tar.xz
pvs-cf1ddf0b9d55b8ca8544b0ae25e8fa08738b2049.zip
Import OpenPGM into the tree, and provide a rudimentary build script.
OpenPGM will serve as the network layer for Multicast File Transfer.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2153497..5e63636 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,12 @@ INCLUDE_DIRECTORIES(
)
################################################################################
+# Build third-party libraries
+################################################################################
+
+ADD_SUBDIRECTORY(3rdparty)
+
+################################################################################
# Variables
################################################################################
@@ -299,23 +305,27 @@ TARGET_LINK_LIBRARIES( pvsmgr
${QT_LIBRARIES}
${VNC_LIBRARIES}
${X11_LIBRARIES}
+ pgm
)
TARGET_LINK_LIBRARIES( pvsmgrtouch
${QT_LIBRARIES}
${VNC_LIBRARIES}
${X11_LIBRARIES}
+ pgm
)
TARGET_LINK_LIBRARIES( pvs
${QT_LIBRARIES}
${VNC_LIBRARIES}
${X11_LIBRARIES}
+ pgm
)
TARGET_LINK_LIBRARIES( pvsgui
${QT_LIBRARIES}
${VNC_LIBRARIES}
+ pgm
)
SET_PROPERTY(TARGET pvsmgrtouch PROPERTY COMPILE_DEFINITIONS MAINWINDOW_USE_TOUCHGUI)