summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-12 21:47:06 +0200
committerPaolo Bonzini2020-08-21 12:30:11 +0200
commit1d7bb6ab2cd93d56a86b9203bfc2cac5ee36de63 (patch)
treec660253b042b1f2011a79e1780d4d067b165eb9f /meson.build
parentcontrib/ivshmem: convert to meson (diff)
downloadqemu-1d7bb6ab2cd93d56a86b9203bfc2cac5ee36de63.tar.gz
qemu-1d7bb6ab2cd93d56a86b9203bfc2cac5ee36de63.tar.xz
qemu-1d7bb6ab2cd93d56a86b9203bfc2cac5ee36de63.zip
contrib/elf2dmp: convert to meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c1078b6759..59ac2f05d9 100644
--- a/meson.build
+++ b/meson.build
@@ -110,6 +110,11 @@ if 'CONFIG_VIRGL' in config_host
virgl = declare_dependency(compile_args: config_host['VIRGL_CFLAGS'].split(),
link_args: config_host['VIRGL_LIBS'].split())
endif
+curl = not_found
+if 'CONFIG_CURL' in config_host
+ curl = declare_dependency(compile_args: config_host['CURL_CFLAGS'].split(),
+ link_args: config_host['CURL_LIBS'].split())
+endif
target_dirs = config_host['TARGET_DIRS'].split()
have_user = false
@@ -274,6 +279,7 @@ qemuutil = declare_dependency(link_with: libqemuutil,
if have_tools
subdir('contrib/rdmacm-mux')
+ subdir('contrib/elf2dmp')
if 'CONFIG_VHOST_USER' in config_host
subdir('contrib/libvhost-user')