summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-16 21:21:02 +0200
committerPaolo Bonzini2020-08-21 12:30:21 +0200
commit2b1ccdf44146424032e384749efa993855f3bda6 (patch)
tree13bf396441fb7b12e88fa501ec8973ab8ec0812f /meson.build
parentmeson: convert audio directory to Meson (diff)
downloadqemu-2b1ccdf44146424032e384749efa993855f3bda6.tar.gz
qemu-2b1ccdf44146424032e384749efa993855f3bda6.tar.xz
qemu-2b1ccdf44146424032e384749efa993855f3bda6.zip
meson: convert ui directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build50
1 files changed, 50 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e1e70d4b48..ca1e6906b7 100644
--- a/meson.build
+++ b/meson.build
@@ -243,6 +243,56 @@ coreaudio = not_found
if 'CONFIG_AUDIO_COREAUDIO' in config_host
coreaudio = declare_dependency(link_args: config_host['COREAUDIO_LIBS'].split())
endif
+opengl = not_found
+if 'CONFIG_OPENGL' in config_host
+ opengl = declare_dependency(link_args: config_host['OPENGL_LIBS'].split())
+else
+endif
+gtk = not_found
+if 'CONFIG_GTK' in config_host
+ gtk = declare_dependency(compile_args: config_host['GTK_CFLAGS'].split(),
+ link_args: config_host['GTK_LIBS'].split())
+endif
+vte = not_found
+if 'CONFIG_VTE' in config_host
+ vte = declare_dependency(compile_args: config_host['VTE_CFLAGS'].split(),
+ link_args: config_host['VTE_LIBS'].split())
+endif
+x11 = not_found
+if 'CONFIG_X11' in config_host
+ x11 = declare_dependency(compile_args: config_host['X11_CFLAGS'].split(),
+ link_args: config_host['X11_LIBS'].split())
+endif
+curses = not_found
+if 'CONFIG_CURSES' in config_host
+ curses = declare_dependency(compile_args: config_host['CURSES_CFLAGS'].split(),
+ link_args: config_host['CURSES_LIBS'].split())
+endif
+iconv = not_found
+if 'CONFIG_ICONV' in config_host
+ iconv = declare_dependency(compile_args: config_host['ICONV_CFLAGS'].split(),
+ link_args: config_host['ICONV_LIBS'].split())
+endif
+gio = not_found
+if 'CONFIG_GIO' in config_host
+ gio = declare_dependency(compile_args: config_host['GIO_CFLAGS'].split(),
+ link_args: config_host['GIO_LIBS'].split())
+endif
+png = not_found
+if 'CONFIG_VNC_PNG' in config_host
+ png = declare_dependency(compile_args: config_host['PNG_CFLAGS'].split(),
+ link_args: config_host['PNG_LIBS'].split())
+endif
+jpeg = not_found
+if 'CONFIG_VNC_JPEG' in config_host
+ jpeg = declare_dependency(compile_args: config_host['JPEG_CFLAGS'].split(),
+ link_args: config_host['JPEG_LIBS'].split())
+endif
+sasl = not_found
+if 'CONFIG_VNC_SASL' in config_host
+ sasl = declare_dependency(compile_args: config_host['SASL_CFLAGS'].split(),
+ link_args: config_host['SASL_LIBS'].split())
+endif
create_config = find_program('scripts/create_config')
minikconf = find_program('scripts/minikconf.py')