summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-02-05 09:45:39 +0100
committerPaolo Bonzini2020-08-21 12:30:09 +0200
commit3f99cf5710d77ce218116d1b6bb9682c466bbde1 (patch)
treeb03f11959ec3ad2d2e206965c02c16d7f7e2d9a6 /meson.build
parentcontrib/libvhost-user: convert to Meson (diff)
downloadqemu-3f99cf5710d77ce218116d1b6bb9682c466bbde1.tar.gz
qemu-3f99cf5710d77ce218116d1b6bb9682c466bbde1.tar.xz
qemu-3f99cf5710d77ce218116d1b6bb9682c466bbde1.zip
tools/virtiofsd: convert to Meson
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 00f17ef36f..00970e6e19 100644
--- a/meson.build
+++ b/meson.build
@@ -83,6 +83,15 @@ if 'CONFIG_GNUTLS' in config_host
gnutls = declare_dependency(compile_args: config_host['GNUTLS_CFLAGS'].split(),
link_args: config_host['GNUTLS_LIBS'].split())
endif
+seccomp = not_found
+if 'CONFIG_SECCOMP' in config_host
+ seccomp = declare_dependency(compile_args: config_host['SECCOMP_CFLAGS'].split(),
+ link_args: config_host['SECCOMP_LIBS'].split())
+endif
+libcap_ng = not_found
+if 'CONFIG_LIBCAP_NG' in config_host
+ libcap_ng = declare_dependency(link_args: config_host['LIBCAP_NG_LIBS'].split())
+endif
target_dirs = config_host['TARGET_DIRS'].split()
have_user = false
@@ -251,6 +260,8 @@ if have_tools
endif
endif
+subdir('tools')
+
summary_info = {}
summary_info += {'Install prefix': config_host['prefix']}
summary_info += {'BIOS directory': config_host['qemu_datadir']}