summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-02-05 09:44:24 +0100
committerPaolo Bonzini2020-08-21 12:30:08 +0200
commit931049b46cb58a499a36d8a1d0ac3f7b334e0876 (patch)
tree098ebbc39c46194a50060a5f2155546f78df9fe2 /meson.build
parentmeson: add version.o (diff)
downloadqemu-931049b46cb58a499a36d8a1d0ac3f7b334e0876.tar.gz
qemu-931049b46cb58a499a36d8a1d0ac3f7b334e0876.tar.xz
qemu-931049b46cb58a499a36d8a1d0ac3f7b334e0876.zip
contrib/libvhost-user: convert to Meson
Since libqemuutil.a has been converted to Meson, the conversion is straightforward. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index feb3c8a30c..00f17ef36f 100644
--- a/meson.build
+++ b/meson.build
@@ -243,6 +243,14 @@ libqemuutil = static_library('qemuutil',
qemuutil = declare_dependency(link_with: libqemuutil,
sources: genh + version_res)
+# Other build targets
+
+if have_tools
+ if 'CONFIG_VHOST_USER' in config_host
+ subdir('contrib/libvhost-user')
+ endif
+endif
+
summary_info = {}
summary_info += {'Install prefix': config_host['prefix']}
summary_info += {'BIOS directory': config_host['qemu_datadir']}