summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2020-08-26 13:04:17 +0200
committerPaolo Bonzini2020-09-01 14:51:33 +0200
commit491e74c158d6bcac3291d2ec354093029169e572 (patch)
treec57f760606c2a80073e16c6d8442e8ef275de5b0 /meson.build
parentmeson: use meson datadir instead of qemu_datadir (diff)
downloadqemu-491e74c158d6bcac3291d2ec354093029169e572.tar.gz
qemu-491e74c158d6bcac3291d2ec354093029169e572.tar.xz
qemu-491e74c158d6bcac3291d2ec354093029169e572.zip
meson: pass docdir option
When cross-compiling, by default qemu_docdir is 'c:\Program Files\QEMU\' which is not recognized as being an absolute path, and meson will end up adding the prefix again. Add an option to pass docdir location to meson, pre-prefixed like we do with other directories, build qemu_docdir with the common suffix and use that instead of config_host['qemu_docdir']. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20200826110419.528931-7-marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6bcfafbc1f..abcfd5cd72 100644
--- a/meson.build
+++ b/meson.build
@@ -19,6 +19,7 @@ enable_modules = 'CONFIG_MODULES' in config_host
enable_static = 'CONFIG_STATIC' in config_host
build_docs = 'BUILD_DOCS' in config_host
qemu_datadir = get_option('datadir') / get_option('qemu_suffix')
+qemu_docdir = get_option('docdir') / get_option('qemu_suffix')
config_host_data = configuration_data()
genh = []
@@ -1182,7 +1183,7 @@ if build_docs
input: input,
output: output,
install: true,
- install_dir: config_host['qemu_docdir'] / 'interop',
+ install_dir: qemu_docdir / 'interop',
command: cmd + args)
endforeach
alias_target(ext, t)
@@ -1245,6 +1246,7 @@ if targetos != 'windows'
else
summary_info += {'local state directory': 'queried at runtime'}
endif
+summary_info += {'Doc directory': get_option('docdir')}
summary_info += {'Build directory': meson.current_build_dir()}
summary_info += {'Source path': meson.current_source_dir()}
summary_info += {'GIT binary': config_host['GIT']}