summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2021-08-27 14:09:00 +0200
committerThomas Huth2021-09-06 09:07:00 +0200
commit6c22853c733efd0a3d243bab48f8af66588f4a7a (patch)
tree5c910f2e9c10383d8680f63a6093afb08b975a70 /meson.build
parentmeson.build: Fix the check for a usable libfdt (diff)
downloadqemu-6c22853c733efd0a3d243bab48f8af66588f4a7a.tar.gz
qemu-6c22853c733efd0a3d243bab48f8af66588f4a7a.tar.xz
qemu-6c22853c733efd0a3d243bab48f8af66588f4a7a.zip
meson.build: Don't use internal libfdt if the user requested the system libfdt
If the users ran configure with --enable-libfdt=system, they likely did that on purpose. We should not silently fall back to the internal libfdt if the system libfdt is not usable, but report the problem with a proper message instead. Message-Id: <20210827120901.150276-3-thuth@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6f7177428e..ecfdce921c 100644
--- a/meson.build
+++ b/meson.build
@@ -1912,6 +1912,8 @@ if have_system
int main(void) { fdt_check_full(NULL, 0); return 0; }''',
dependencies: fdt)
fdt_opt = 'system'
+ elif fdt_opt == 'system'
+ error('system libfdt requested, but it is too old (1.5.1 or newer required)')
elif have_internal
fdt_opt = 'internal'
else