summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-10-06 14:55:58 +0200
committerPaolo Bonzini2020-10-12 17:50:20 +0200
commit7e6edef3f8cd1176d267c86151c9cf2fc0777781 (patch)
treec3a6aaa24059b00f66b3ee17738b80f803e7a82a /meson.build
parentchardev: Move the creation of the library to the main meson.build (diff)
downloadqemu-7e6edef3f8cd1176d267c86151c9cf2fc0777781.tar.gz
qemu-7e6edef3f8cd1176d267c86151c9cf2fc0777781.tar.xz
qemu-7e6edef3f8cd1176d267c86151c9cf2fc0777781.zip
migration: Move the creation of the library to the main meson.build
Be consistent creating all the libraries in the main meson.build file. Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20201006125602.2311423-6-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 39fc074977..dce48d8304 100644
--- a/meson.build
+++ b/meson.build
@@ -1451,6 +1451,13 @@ qemu_syms = custom_target('qemu.syms', output: 'qemu.syms',
# Library dependencies #
########################
+libmigration = static_library('migration', sources: migration_files + genh,
+ name_suffix: 'fa',
+ build_by_default: false)
+migration = declare_dependency(link_with: libmigration,
+ dependencies: [zlib, qom, io])
+softmmu_ss.add(migration)
+
block_ss = block_ss.apply(config_host, strict: false)
libblock = static_library('block', block_ss.sources() + genh,
dependencies: block_ss.dependencies(),