summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-10-06 14:55:57 +0200
committerPaolo Bonzini2020-10-12 17:50:19 +0200
commitc2306d713e4cfc95c25b395133e00a31d4e022c1 (patch)
tree7441acdf8574361b1b6a17407f5d45d5c997da11 /meson.build
parenthw/core: Move the creation of the library to the main meson.build (diff)
downloadqemu-c2306d713e4cfc95c25b395133e00a31d4e022c1.tar.gz
qemu-c2306d713e4cfc95c25b395133e00a31d4e022c1.tar.xz
qemu-c2306d713e4cfc95c25b395133e00a31d4e022c1.zip
chardev: Move the creation of the library to the main meson.build
Be consistent creating all the libraries in the main meson.build file. Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20201006125602.2311423-5-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6c760b4163..39fc074977 100644
--- a/meson.build
+++ b/meson.build
@@ -1185,6 +1185,7 @@ sphinx_extn_depends = [ meson.source_root() / 'docs/sphinx/depfile.py',
blockdev_ss = ss.source_set()
block_ss = ss.source_set()
bsd_user_ss = ss.source_set()
+chardev_ss = ss.source_set()
common_ss = ss.source_set()
linux_user_ss = ss.source_set()
qmp_ss = ss.source_set()
@@ -1469,6 +1470,12 @@ libqmp = static_library('qmp', qmp_ss.sources() + genh,
qmp = declare_dependency(link_whole: [libqmp])
+libchardev = static_library('chardev', chardev_ss.sources() + genh,
+ name_suffix: 'fa',
+ build_by_default: false)
+
+chardev = declare_dependency(link_whole: libchardev)
+
libhwcore = static_library('hwcore', sources: hwcore_files + genh,
name_suffix: 'fa',
build_by_default: false)