summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-16 19:54:15 +0200
committerPaolo Bonzini2020-08-21 12:30:18 +0200
commit897b5afae57bbfa2af928a8c381465209d178e5b (patch)
tree25db75c5c12fc56210908b97192f1e691a4d2336 /meson.build
parentmeson: qemu-{img,io,nbd} (diff)
downloadqemu-897b5afae57bbfa2af928a8c381465209d178e5b.tar.gz
qemu-897b5afae57bbfa2af928a8c381465209d178e5b.tar.xz
qemu-897b5afae57bbfa2af928a8c381465209d178e5b.zip
meson: qemu-pr-helper
The executable moves back from libexecdir to bindir, when it was in 5.0 and earlier. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7f753afc6e..3a8cf11edc 100644
--- a/meson.build
+++ b/meson.build
@@ -148,6 +148,10 @@ if 'CONFIG_XKBCOMMON' in config_host
link_args: config_host['XKBCOMMON_LIBS'].split())
endif
rt = cc.find_library('rt', required: false)
+libmpathpersist = not_found
+if config_host.has_key('CONFIG_MPATH')
+ libmpathpersist = cc.find_library('mpathpersist')
+endif
libiscsi = not_found
if 'CONFIG_LIBISCSI' in config_host
libiscsi = declare_dependency(compile_args: config_host['LIBISCSI_CFLAGS'].split(),
@@ -633,6 +637,7 @@ foreach target : target_dirs
endforeach
# Other build targets
+
if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')
endif
@@ -674,6 +679,11 @@ if have_tools
dependencies: [qemuutil, libcap_ng],
install: true,
install_dir: get_option('libexecdir'))
+
+ executable('qemu-pr-helper', files('scsi/qemu-pr-helper.c', 'scsi/utils.c'),
+ dependencies: [authz, crypto, io, qom, qemuutil,
+ libcap_ng, libudev, libmpathpersist],
+ install: true)
endif
if 'CONFIG_IVSHMEM' in config_host