summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel P. Berrangé2021-07-09 16:29:31 +0200
committerAlex Bennée2021-07-14 15:31:48 +0200
commit8f4aea712ffc4f2c20c293dac26df8688f497a9f (patch)
tree49aa76e54f006e4d1ee78d08b9802ef21cfbd582 /meson.build
parentdisable modular TCG on Darwin (diff)
downloadqemu-8f4aea712ffc4f2c20c293dac26df8688f497a9f.tar.gz
qemu-8f4aea712ffc4f2c20c293dac26df8688f497a9f.tar.xz
qemu-8f4aea712ffc4f2c20c293dac26df8688f497a9f.zip
build: validate that system capstone works before using it
Some versions of capstone have shipped a broken pkg-config file which puts the -I path without the trailing '/capstone' suffix. This breaks the ability to "#include <capstone.h>". Upstream and most distros have fixed this, but a few stragglers remain, notably FreeBSD. Signed-off-by: Daniel P. Berrangé <berrange@redhat.com> Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Reviewed-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Willian Rampazzo <willianr@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20210625172211.451010-2-berrange@redhat.com> Message-Id: <20210709143005.1554-7-alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 512ee2e926..89c09ed7ea 100644
--- a/meson.build
+++ b/meson.build
@@ -1657,6 +1657,19 @@ if capstone_opt in ['enabled', 'auto', 'system']
kwargs: static_kwargs, method: 'pkg-config',
required: capstone_opt == 'system' or
capstone_opt == 'enabled' and not have_internal)
+
+ # Some versions of capstone have broken pkg-config file
+ # that reports a wrong -I path, causing the #include to
+ # fail later. If the system has such a broken version
+ # do not use it.
+ if capstone.found() and not cc.compiles('#include <capstone.h>',
+ dependencies: [capstone])
+ capstone = not_found
+ if capstone_opt == 'system'
+ error('system capstone requested, it does not appear to work')
+ endif
+ endif
+
if capstone.found()
capstone_opt = 'system'
elif have_internal