summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-01-21 10:56:09 +0100
committerPaolo Bonzini2021-01-23 21:55:05 +0100
commit983d0a75c00a7f11b4b00a752fbd7da42fc47aa8 (patch)
tree3ce3a9b607899571f192e40247ff085fbe32bd2d /meson.build
parentmeson: convert wixl detection to Meson (diff)
downloadqemu-983d0a75c00a7f11b4b00a752fbd7da42fc47aa8.tar.gz
qemu-983d0a75c00a7f11b4b00a752fbd7da42fc47aa8.tar.xz
qemu-983d0a75c00a7f11b4b00a752fbd7da42fc47aa8.zip
meson: Summarize information related to directories first
Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20210121095616.1471869-2-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 430942c8b4..2483dd7bac 100644
--- a/meson.build
+++ b/meson.build
@@ -2287,6 +2287,7 @@ endif
# Configuration summary #
#########################
+# Directories
summary_info = {}
summary_info += {'Install prefix': get_option('prefix')}
summary_info += {'BIOS directory': qemu_datadir}
@@ -2306,8 +2307,11 @@ endif
summary_info += {'Doc directory': get_option('docdir')}
summary_info += {'Build directory': meson.current_build_dir()}
summary_info += {'Source path': meson.current_source_dir()}
-summary_info += {'GIT binary': config_host['GIT']}
summary_info += {'GIT submodules': config_host['GIT_SUBMODULES']}
+summary(summary_info, bool_yn: true, section: 'Directories')
+
+summary_info = {}
+summary_info += {'GIT binary': config_host['GIT']}
summary_info += {'C compiler': meson.get_compiler('c').cmd_array()[0]}
summary_info += {'Host C compiler': meson.get_compiler('c', native: true).cmd_array()[0]}
if link_language == 'cpp'