summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-11-17 12:36:15 +0100
committerPaolo Bonzini2021-01-02 21:03:36 +0100
commita0fbbb6eb8b52b88e1756814dc661edd747ec481 (patch)
tree93dff10161d70e827a1ff11a56409aca5b3c8546 /meson.build
parentmeson: fix detection of curses with pkgconfig (diff)
downloadqemu-a0fbbb6eb8b52b88e1756814dc661edd747ec481.tar.gz
qemu-a0fbbb6eb8b52b88e1756814dc661edd747ec481.tar.xz
qemu-a0fbbb6eb8b52b88e1756814dc661edd747ec481.zip
meson: use pkg-config method for libudev
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 022272f4cf..0e70fe7a89 100644
--- a/meson.build
+++ b/meson.build
@@ -403,6 +403,7 @@ endif
libudev = not_found
if targetos == 'linux' and (have_system or have_tools)
libudev = dependency('libudev',
+ method: 'pkg-config',
required: get_option('libudev'),
static: enable_static)
endif