summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-24 17:23:16 +0200
committerPaolo Bonzini2020-08-21 12:30:23 +0200
commitab3180515c6a5f080623cde07c9b89ece77abb19 (patch)
tree4a5d2c16c307f1914adfa42fcaed3ecf6c108d0c /meson.build
parentmeson: convert net directory to Meson (diff)
downloadqemu-ab3180515c6a5f080623cde07c9b89ece77abb19.tar.gz
qemu-ab3180515c6a5f080623cde07c9b89ece77abb19.tar.xz
qemu-ab3180515c6a5f080623cde07c9b89ece77abb19.zip
meson: convert backends directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ead9420844..06755f34b3 100644
--- a/meson.build
+++ b/meson.build
@@ -321,6 +321,10 @@ rdma = not_found
if 'CONFIG_RDMA' in config_host
rdma = declare_dependency(link_args: config_host['RDMA_LIBS'].split())
endif
+numa = not_found
+if 'CONFIG_NUMA' in config_host
+ numa = declare_dependency(link_args: config_host['NUMA_LIBS'].split())
+endif
create_config = find_program('scripts/create_config')
minikconf = find_program('scripts/minikconf.py')
@@ -668,6 +672,7 @@ softmmu_ss.add(when: ['CONFIG_FDT', fdt], if_true: [files('device_tree.c')])
common_ss.add(files('cpus-common.c'))
subdir('softmmu')
+subdir('backends')
subdir('migration')
subdir('monitor')
subdir('net')