summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-22 21:47:50 +0200
committerPaolo Bonzini2020-08-21 12:30:23 +0200
commitcdaf07228cf42d708fe24371a68cec022841e018 (patch)
tree314dea957075960791922c9749c680fcbc86e88a /meson.build
parentmeson: convert migration directory to Meson (diff)
downloadqemu-cdaf07228cf42d708fe24371a68cec022841e018.tar.gz
qemu-cdaf07228cf42d708fe24371a68cec022841e018.tar.xz
qemu-cdaf07228cf42d708fe24371a68cec022841e018.zip
meson: convert net directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9bc1a2ac0d..ead9420844 100644
--- a/meson.build
+++ b/meson.build
@@ -149,6 +149,15 @@ if 'CONFIG_XKBCOMMON' in config_host
xkbcommon = declare_dependency(compile_args: config_host['XKBCOMMON_CFLAGS'].split(),
link_args: config_host['XKBCOMMON_LIBS'].split())
endif
+slirp = not_found
+if config_host.has_key('CONFIG_SLIRP')
+ slirp = declare_dependency(compile_args: config_host['SLIRP_CFLAGS'].split(),
+ link_args: config_host['SLIRP_LIBS'].split())
+endif
+vde = not_found
+if config_host.has_key('CONFIG_VDE')
+ vde = declare_dependency(link_args: config_host['VDE_LIBS'].split())
+endif
pulse = not_found
if 'CONFIG_LIBPULSE' in config_host
pulse = declare_dependency(compile_args: config_host['PULSE_CFLAGS'].split(),
@@ -661,6 +670,7 @@ common_ss.add(files('cpus-common.c'))
subdir('softmmu')
subdir('migration')
subdir('monitor')
+subdir('net')
subdir('replay')
# needed for fuzzing binaries