summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-06-03 12:50:17 +0200
committerPaolo Bonzini2021-07-06 08:33:51 +0200
commitccd250aa2d8e214195d5cee37c1ddc58e123b821 (patch)
tree5577c71f7ccd01456c65a7f176803b67cbd2924b /meson.build
parentmeson: store dependency('threads') in a variable (diff)
downloadqemu-ccd250aa2d8e214195d5cee37c1ddc58e123b821.tar.gz
qemu-ccd250aa2d8e214195d5cee37c1ddc58e123b821.tar.xz
qemu-ccd250aa2d8e214195d5cee37c1ddc58e123b821.zip
configure, meson: move CONFIG_IVSHMEM to meson
This is a duplicate of CONFIG_EVENTFD, handle it directly in meson.build. Reviewed-by: Daniel P. Berrangé <berrange@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e288e4c21c..b5dcc3d70e 100644
--- a/meson.build
+++ b/meson.build
@@ -1335,10 +1335,11 @@ if link_language == 'cpp'
}
endif
+have_ivshmem = config_host.has_key('CONFIG_EVENTFD')
host_kconfig = \
('CONFIG_TPM' in config_host ? ['CONFIG_TPM=y'] : []) + \
('CONFIG_SPICE' in config_host ? ['CONFIG_SPICE=y'] : []) + \
- ('CONFIG_IVSHMEM' in config_host ? ['CONFIG_IVSHMEM=y'] : []) + \
+ (have_ivshmem ? ['CONFIG_IVSHMEM=y'] : []) + \
('CONFIG_OPENGL' in config_host ? ['CONFIG_OPENGL=y'] : []) + \
(x11.found() ? ['CONFIG_X11=y'] : []) + \
('CONFIG_VHOST_USER' in config_host ? ['CONFIG_VHOST_USER=y'] : []) + \
@@ -2489,7 +2490,7 @@ if have_tools
install: true)
endif
- if 'CONFIG_IVSHMEM' in config_host
+ if have_ivshmem
subdir('contrib/ivshmem-client')
subdir('contrib/ivshmem-server')
endif