summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-08-20 17:48:59 +0200
committerPaolo Bonzini2020-08-21 12:30:11 +0200
commitd92989aa2e2d0a5c3de80404b33d96e9afae84d3 (patch)
tree1903b83420c5daff029223e352d30ec37984ed2c /meson.build
parentcontrib/elf2dmp: convert to meson (diff)
downloadqemu-d92989aa2e2d0a5c3de80404b33d96e9afae84d3.tar.gz
qemu-d92989aa2e2d0a5c3de80404b33d96e9afae84d3.tar.xz
qemu-d92989aa2e2d0a5c3de80404b33d96e9afae84d3.zip
meson: add macos dependencies
There is no probing in configure, so no need to pass them as variables to meson. Do a regular meson dependency() instead. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 59ac2f05d9..d9758629cc 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,10 @@ m = cc.find_library('m', required: false)
util = cc.find_library('util', required: false)
socket = []
version_res = []
+coref = []
+iokit = []
+cocoa = []
+hvf = []
if targetos == 'windows'
socket = cc.find_library('ws2_32')
@@ -57,6 +61,11 @@ if targetos == 'windows'
version_res = win.compile_resources('version.rc',
depend_files: files('pc-bios/qemu-nsis.ico'),
include_directories: include_directories('.'))
+elif targetos == 'darwin'
+ coref = dependency('appleframeworks', modules: 'CoreFoundation')
+ iokit = dependency('appleframeworks', modules: 'IOKit')
+ cocoa = dependency('appleframeworks', modules: 'Cocoa')
+ hvf = dependency('appleframeworks', modules: 'Hypervisor')
endif
glib = declare_dependency(compile_args: config_host['GLIB_CFLAGS'].split(),
link_args: config_host['GLIB_LIBS'].split())