summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-10-06 14:56:02 +0200
committerPaolo Bonzini2020-10-12 17:50:20 +0200
commitda33fc09873af7ee5f60dbd0b09d30926f9cb851 (patch)
tree5d537a0df886c27e4ac596656652a77b7a0a7b5a /meson.build
parentauthz: Move the creation of the library to the main meson.build (diff)
downloadqemu-da33fc09873af7ee5f60dbd0b09d30926f9cb851.tar.gz
qemu-da33fc09873af7ee5f60dbd0b09d30926f9cb851.tar.xz
qemu-da33fc09873af7ee5f60dbd0b09d30926f9cb851.zip
qom: Move the creation of the library to the main meson.build
Be consistent creating all the libraries in the main meson.build file. Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20201006125602.2311423-10-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2736f74b8f..f4ef3b83f3 100644
--- a/meson.build
+++ b/meson.build
@@ -1192,6 +1192,7 @@ crypto_ss = ss.source_set()
io_ss = ss.source_set()
linux_user_ss = ss.source_set()
qmp_ss = ss.source_set()
+qom_ss = ss.source_set()
softmmu_ss = ss.source_set()
specific_fuzz_ss = ss.source_set()
specific_ss = ss.source_set()
@@ -1454,6 +1455,13 @@ qemu_syms = custom_target('qemu.syms', output: 'qemu.syms',
# Library dependencies #
########################
+qom_ss = qom_ss.apply(config_host, strict: false)
+libqom = static_library('qom', qom_ss.sources() + genh,
+ dependencies: [qom_ss.dependencies()],
+ name_suffix: 'fa')
+
+qom = declare_dependency(link_whole: libqom)
+
authz_ss = authz_ss.apply(config_host, strict: false)
libauthz = static_library('authz', authz_ss.sources() + genh,
dependencies: [authz_ss.dependencies()],