summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-10-06 14:55:59 +0200
committerPaolo Bonzini2020-10-12 17:50:20 +0200
commitf78536b149b7c4caa7e33e7f6b2871c12b14e9bb (patch)
treebf5aa379df6d97c3568e85ec7ec26b41ebcf0335 /meson.build
parentmigration: Move the creation of the library to the main meson.build (diff)
downloadqemu-f78536b149b7c4caa7e33e7f6b2871c12b14e9bb.tar.gz
qemu-f78536b149b7c4caa7e33e7f6b2871c12b14e9bb.tar.xz
qemu-f78536b149b7c4caa7e33e7f6b2871c12b14e9bb.zip
io: Move the creation of the library to the main meson.build
Be consistent creating all the libraries in the main meson.build file. Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20201006125602.2311423-7-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dce48d8304..28f31e6022 100644
--- a/meson.build
+++ b/meson.build
@@ -1187,6 +1187,7 @@ block_ss = ss.source_set()
bsd_user_ss = ss.source_set()
chardev_ss = ss.source_set()
common_ss = ss.source_set()
+io_ss = ss.source_set()
linux_user_ss = ss.source_set()
qmp_ss = ss.source_set()
softmmu_ss = ss.source_set()
@@ -1451,6 +1452,15 @@ qemu_syms = custom_target('qemu.syms', output: 'qemu.syms',
# Library dependencies #
########################
+io_ss = io_ss.apply(config_host, strict: false)
+libio = static_library('io', io_ss.sources() + genh,
+ dependencies: [io_ss.dependencies()],
+ link_with: libqemuutil,
+ name_suffix: 'fa',
+ build_by_default: false)
+
+io = declare_dependency(link_whole: libio, dependencies: [crypto, qom])
+
libmigration = static_library('migration', sources: migration_files + genh,
name_suffix: 'fa',
build_by_default: false)