summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9bc1a2ac0d..ead9420844 100644
--- a/meson.build
+++ b/meson.build
@@ -149,6 +149,15 @@ if 'CONFIG_XKBCOMMON' in config_host
xkbcommon = declare_dependency(compile_args: config_host['XKBCOMMON_CFLAGS'].split(),
link_args: config_host['XKBCOMMON_LIBS'].split())
endif
+slirp = not_found
+if config_host.has_key('CONFIG_SLIRP')
+ slirp = declare_dependency(compile_args: config_host['SLIRP_CFLAGS'].split(),
+ link_args: config_host['SLIRP_LIBS'].split())
+endif
+vde = not_found
+if config_host.has_key('CONFIG_VDE')
+ vde = declare_dependency(link_args: config_host['VDE_LIBS'].split())
+endif
pulse = not_found
if 'CONFIG_LIBPULSE' in config_host
pulse = declare_dependency(compile_args: config_host['PULSE_CFLAGS'].split(),
@@ -661,6 +670,7 @@ common_ss.add(files('cpus-common.c'))
subdir('softmmu')
subdir('migration')
subdir('monitor')
+subdir('net')
subdir('replay')
# needed for fuzzing binaries