summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Andersen2004-02-06 23:52:14 +0100
committerEric Andersen2004-02-06 23:52:14 +0100
commit0209686130ce8721ddc03f481a39940dbbbb82cb (patch)
tree813ba3b917a9c89ecba64a327441c93b532ca3bd
parentAdd a check to ensure the proper utilities are installed before (diff)
downloadbuildroot-0209686130ce8721ddc03f481a39940dbbbb82cb.tar.gz
buildroot-0209686130ce8721ddc03f481a39940dbbbb82cb.tar.xz
buildroot-0209686130ce8721ddc03f481a39940dbbbb82cb.zip
Update to the February ltp-full-20040206 testsuite
-rw-r--r--make/ltp-testsuite.mk4
-rw-r--r--sources/ltp-testsuite.patch30
2 files changed, 2 insertions, 32 deletions
diff --git a/make/ltp-testsuite.mk b/make/ltp-testsuite.mk
index c11b89672..cb4a0161d 100644
--- a/make/ltp-testsuite.mk
+++ b/make/ltp-testsuite.mk
@@ -3,10 +3,10 @@
# ltp-testsuite
#
#############################################################
-LTP_TESTSUITE_SOURCE:=ltp-full-20040108.tgz
+LTP_TESTSUITE_SOURCE:=ltp-full-20040206.tgz
LTP_TESTSUITE_SITE:=http://aleron.dl.sourceforge.net/sourceforge/ltp
LTP_TESTSUITE_CAT:=zcat
-LTP_TESTSUITE_DIR:=$(BUILD_DIR)/ltp-full-20040108
+LTP_TESTSUITE_DIR:=$(BUILD_DIR)/ltp-full-20040206
LTP_TESTSUITE_PATCH:=$(SOURCE_DIR)/ltp-testsuite.patch
diff --git a/sources/ltp-testsuite.patch b/sources/ltp-testsuite.patch
index 89db9814e..fed728e97 100644
--- a/sources/ltp-testsuite.patch
+++ b/sources/ltp-testsuite.patch
@@ -57,33 +57,3 @@
@echo 'NPtcp has been built.'
NPtcp-ipv6: NPtcp.o TCP.o
---- ltp-full-20031106/testcases/kernel/syscalls/string/string01.orig.c 2004-01-01 23:54:37.000000000 -0700
-+++ ltp-full-20031106/testcases/kernel/syscalls/string/string01.c 2004-01-01 23:55:48.000000000 -0700
-@@ -413,10 +413,10 @@
- //fprintf(temp, "\tStrncmp\n" );
- i = 0;
- while ( t_ncmp[i].s1 ) {
-- if ((n = strncmp( t_ncmp[i].s1, t_ncmp[i].s2, t_ncmp[i].n ))
-- != t_ncmp[i].e_res) {
-+ n = strncmp( t_ncmp[i].s1, t_ncmp[i].s2, t_ncmp[i].n );
-+ if (sign(n) != sign(t_ncmp[i].e_res)) {
- fprintf(temp, "(Strncmp) test %d: expected %d, got %d",
-- i, t_ncmp[i].e_res, n );
-+ i, sign(t_ncmp[i].e_res), sign(n) );
- local_flag = FAILED;
- }
- i++;
---- ltp-full-20040108/testcases/kernel/syscalls/pipe/pipe07.c.orig 2003-12-15 10:08:10.000000000 -0700
-+++ ltp-full-20040108/testcases/kernel/syscalls/pipe/pipe07.c 2004-01-11 00:55:55.000000000 -0700
-@@ -84,8 +84,9 @@
- setup();
- /* Get the currently used number of file descriptors */
- mypid=getpid();
-- cmdstring=malloc(sizeof(cmdstring));
-- sprintf(cmdstring,"ls -A -1 /proc/%d/fd | wc -l | awk {'print $1'}> pipe07.tmp",mypid);
-+ cmdstring=malloc(BUFSIZ);
-+ snprintf(cmdstring, BUFSIZ, "ls -A -1 /proc/%d/fd | "
-+ "wc -l | awk {'print $1'}> pipe07.tmp", mypid);
- if (system(cmdstring) == 0)
- {
- f = fopen("pipe07.tmp", "r");